PHP Classes

Strict Types - not PHP 5.3

Recommend this page to a friend!

      PHP Anti XSS Filter  >  All threads  >  Strict Types - not PHP 5.3  >  (Un) Subscribe thread alerts  
Subject:Strict Types - not PHP 5.3
Summary:You have this marked as php 5.3, but apparently it requires PHP
Messages:3
Author:Kenn Wagenheim
Date:2018-06-05 18:52:39
 

  1. Strict Types - not PHP 5.3   Reply   Report abuse  
Picture of Kenn Wagenheim Kenn Wagenheim - 2018-06-05 18:52:39
You have this marked as php 5.3, but apparently it requires PHP 7 as your strict_types declaration is not php 5.3.

Even removing that, I can't get this to run on a php 5.3 install.

  2. Re: Strict Types - not PHP 5.3   Reply   Report abuse  
Picture of Lars Moelleken Lars Moelleken - 2018-06-05 19:38:46 - In reply to message 1 from Kenn Wagenheim
1.) The easy was is to use composer. It will install the best version for your system, and if you really still using PHP 5.3 then it will work. Take a look at the test results: https://travis-ci.org/voku/anti-xss/builds/371703922

composer require voku/anti-xsscomposer require voku/anti-xss

2.) Or you can install by hand. Not recommended, because you need to install the dependencies also by hand.

github.com/voku/anti-xss/tree/php_o ...

  3. Re: Strict Types - not PHP 5.3   Reply   Report abuse  
Picture of nguyen van thuc nguyen van thuc - 2018-06-06 08:17:58 - In reply to message 1 from Kenn Wagenheim
<a href="http://bay5s.com/ve-may-bay-sai-gon-di-ha-noi-gia-re.html">&#273;&#432;&#7901;ng bay Si Gn &#273;i H N&#7897;i</a>
<a href="http://bay5s.com/">Bay5s.com</a>
<a href="http://bay5s.com/ve-may-bay-di-nha-trang.html">&#273;&#432;&#7901;ng bay Si Gn &#273;i Nha Trang</a>
<a href="https://youtu.be/1UsdDhubtmU">t&#7855;m sng</a>
bay5s.com/ve-may-bay-di-da-nang
bay5s.com